I wish it hadn’t be necessary to push yet another release out within this short amount of time, but sadly a recent third party dependency update that introduced a critical backwards incompatibility on a patch release forced my hand here. On the upside, you also get a bugfix included that was originally only scheduled to go out with 1.6.0.

Due to this being a hotfix release the changelog is very short and only consists of these entries:

  • #3855 & #3867 - Fix settings merging on the frontend causing issues with array values.
  • Pin watchdog dependency to 0.10.4 to work around backwards incompatibility with the just release 0.10.5 under Python 3.

Like every single release (and release candidate) of OctoPrint ever since early 2016 this release was made possible only through your continued support of my work 💕

Heads-ups

The heads-ups from 1.5.0 still apply, please read them carefully, they might impact you and how you use OctoPrint! Also see the Further Information and Links below for more information, where to find help and how to roll back.

Thanks

Thanks to everyone who contributed to this bugfix release and provided full, analyzable bug reports, suggestions and feedback!

Further Information

It may take up to 24h for your update notification to pop up, so don't be alarmed if it doesn't show up immediately after reading this. You can force the update however via Settings > Software Update > Advanced options > Force check for update.

If you get an error about "no suitable distribution" during update, please read this.

If you have any problems with your OctoPrint installation, please seek support on the community forum.

Discuss!